re = /^(?:(?:\d{7}|3\d{9})(?:,(?=\d)|$))+$/m
str = '5461500,3256990012,8122715,3148419530'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end