import re
regex = re.compile(r"[8,9]", flags=re.MULTILINE)
test_str = "I have a regex that matches (8/10) or (9/10) or (10/10) which is good but it also matches (0/10) "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")