#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*(?:\bjardim\s+guanabara\b|\bjd\s+guanabara\b|\bjd\s+gb\b|\bnorte\b|\bzona\s+norte\b|\bvale\s+dos\b\s+sonhos\b|\basa\s+branca\b|\bjoao\s+paulo\b)).*$"
Local $sString = "I want to search for this words jardim guanabara." & @CRLF & _
"I want to search for this words jd guanabara." & @CRLF & _
"I want to search for this words jd gb." & @CRLF & _
"I want to search for this words norte." & @CRLF & _
"I want to search for this words zona norte." & @CRLF & _
"I want to search for this words vale dos sonhos." & @CRLF & _
"I want to search for this words asa branca and joao paulo." & @CRLF & _
"" & @CRLF & _
"I don't want to search for this words nojardim guanabara." & @CRLF & _
"I don't want to search for this words nojd guanabara." & @CRLF & _
"I don't want to search for this words nojd gb." & @CRLF & _
"I don't want to search for this words nonorte." & @CRLF & _
"I don't want to search for this words nozona norte." & @CRLF & _
"I don't want to search for this words novale dos sonhos." & @CRLF & _
"I don't want to search for this words noasa branca and joao paulo." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")