$re = '/^(?=.*(?:\bjardim\s+guanabara\b|\bjd\s+guanabara\b|\bjd\s+gb\b|\bnorte\b|\bzona\s+norte\b|\bvale\s+dos\b\s+sonhos\b|\basa\s+branca\b|\bjoao\s+paulo\b)).*$/m';
$str = 'I want to search for this words jardim guanabara.
I want to search for this words jd guanabara.
I want to search for this words jd gb.
I want to search for this words norte.
I want to search for this words zona norte.
I want to search for this words vale dos sonhos.
I want to search for this words asa branca and joao paulo.
I don\'t want to search for this words nojardim guanabara.
I don\'t want to search for this words nojd guanabara.
I don\'t want to search for this words nojd gb.
I don\'t want to search for this words nonorte.
I don\'t want to search for this words nozona norte.
I don\'t want to search for this words novale dos sonhos.
I don\'t want to search for this words noasa branca and joao paulo.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);