import re
regex = re.compile(r"^(?=.{5}$)[a-z]*\d[a-z]*$", flags=re.MULTILINE)
test_str = ("jlwk6\n"
"bjkgp\n"
"5fm8s\n"
"x975t\n"
"k88q5\n"
"zl796\n"
"qm9hb\n"
"h6gtf\n"
"9rm9p\n"
"jwzw2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")