package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/([^\/:]+\.[a-zA-Z]{2,10}|([0-9]{1,3}\.){3}[0-9]{1,3})(:[0-9]+)?((\/|\?).*)?`)
var str = `http://xxx.yyy.zz/exampleofurl containinganannoyingcarriagereturn`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}