const regex = /https?:\/\/([^\/:]+\.[a-zA-Z]{2,10}|([0-9]{1,3}\.){3}[0-9]{1,3})(:[0-9]+)?((\/|\?).*)?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/([^\\\/:]+\\.[a-zA-Z]{2,10}|([0-9]{1,3}\\.){3}[0-9]{1,3})(:[0-9]+)?((\\\/|\\?).*)?', '')
const str = `http://xxx.yyy.zz/exampleofurl containinganannoyingcarriagereturn`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}