const regex = /(?P<protocol>\w+)\s*request\s*from\s*(?P<source_address>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}):(?P<source_port>\d+)\s*to\s*(?P<destination_address>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}):(?P<destination_port>\d+).\s*Action:\s*(?P<action>\w+).\s*Rule\s*Collection:\s*(?P<rule_collection>[^\s.]+).\s*Rule:\s*(?P<rule>[^\s}]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<protocol>\\w+)\\s*request\\s*from\\s*(?P<source_address>\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3}):(?P<source_port>\\d+)\\s*to\\s*(?P<destination_address>\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3}):(?P<destination_port>\\d+).\\s*Action:\\s*(?P<action>\\w+).\\s*Rule\\s*Collection:\\s*(?P<rule_collection>[^\\s.]+).\\s*Rule:\\s*(?P<rule>[^\\s}]+)', 'gm')
const str = `UDP request from 20.0.1.42:34315 to 8.8.8.8:53. Action: Allow. Rule Collection: wfx-us-east-prod-allow-internet. Rule: allow-internet
TCP request from 162.158.79.116:45646 to 52.191.237.198:443 was DNAT'ed to 20.0.1.28:443. Rule Collection: wfx-us-east-prod-nat-rules. Rule: collector-02}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}