$re = '/^data:(?<Mime>.*?);base64.*$/';
$str = 'data:application/pdf;base64......etc.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);