re = /^data:(?<Mime>.*?);base64.*$/
str = 'data:application/pdf;base64......etc.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end