package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9][0-9][0-9]:([0-1][0-9]|[2][0-3]):([0][1-9]|[1-5][0-9]))|([0-9][0-9][0-9]:([0][1-9]|([1][0-9])|[2][0-4]):[0-5][0-9])|(([0-9][0-9][1-9]|[0-9][1-9][0-9]|[1-9][0-9][0-9]):([0-1][0-9]|[2][0-4]):[0-5][0-9])`)
var str = `001:00:00`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}