const regex = /((?<=url\(\')(?:[^'\/]+\/)+)((?<=\/)[^\/']+(?=\'))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<=url\\(\\\')(?:[^\'\\\/]+\\\/)+)((?<=\\\/)[^\\\/\']+(?=\\\'))', 'g')
const str = `src: url('../fonts/fontawesome-webfont.eot?#iefix&v=4.0.1') format('embedded-opentype'), url('../fonts/fontawesome-webfont.woff?v=4.0.1') format('woff'), url('../fonts/fontawesome-webfont.ttf?v=4.0.1') format('truetype'), url('../fonts/fontawesome-webfont.svg?v=4.0.1#fontawesomeregular') format('svg');`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}