$re = '/((?<=url\(\')(?:[^\'\/]+\/)+)((?<=\/)[^\/\']+(?=\'))/';
$str = 'src: url(\'../fonts/fontawesome-webfont.eot?#iefix&v=4.0.1\') format(\'embedded-opentype\'), url(\'../fonts/fontawesome-webfont.woff?v=4.0.1\') format(\'woff\'), url(\'../fonts/fontawesome-webfont.ttf?v=4.0.1\') format(\'truetype\'), url(\'../fonts/fontawesome-webfont.svg?v=4.0.1#fontawesomeregular\') format(\'svg\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);