using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]*)(?=<\/option>)";
string input = @"<select name=""ctl00$ContentPlaceHolder1$ddlyear"" onchange=""javascript:setTimeout('__doPostBack(\'ctl00$ContentPlaceHolder1$ddlyear\',\'\')', 0)"" id=""ctl00_ContentPlaceHolder1_ddlyear"" class=""page-heading"" style=""background-color: rgb(255, 244, 244); width: 95px; outline: 1px solid blue;""> <option selected=""selected"" value=""Select Year"">Select Year</option> <option value=""2000"">2000</option>
<option value=""2001"">2001</option>
<option value=""2002"">2002</option>
<option value=""2003"">2003</option>
<option value=""2004"">2004</option>
<option value=""2005"">2005</option>
<option value=""2006"">2006</option>
<option value=""2007"">2007</option>
<option value=""2008"">2008</option>
<option value=""2009"">2009</option>
<option value=""2010"">2010</option>
<option value=""2011"">2011</option>
<option value=""2012"">2012</option>
<option value=""2013"">2013</option>
<option value=""2014"">2014</option>
<option value=""2015"">2015</option>
<option value=""2016"">2016</option>
<option value=""2017"">2017</option>
</select>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}