import re
regex = re.compile(r"([0-9]*)(?=<\/option>)")
test_str = ("<select name=\"ctl00$ContentPlaceHolder1$ddlyear\" onchange=\"javascript:setTimeout('__doPostBack(\\'ctl00$ContentPlaceHolder1$ddlyear\\',\\'\\')', 0)\" id=\"ctl00_ContentPlaceHolder1_ddlyear\" class=\"page-heading\" style=\"background-color: rgb(255, 244, 244); width: 95px; outline: 1px solid blue;\"> <option selected=\"selected\" value=\"Select Year\">Select Year</option> <option value=\"2000\">2000</option> \n"
"<option value=\"2001\">2001</option> \n"
"<option value=\"2002\">2002</option> \n"
"<option value=\"2003\">2003</option> \n"
"<option value=\"2004\">2004</option>\n"
"<option value=\"2005\">2005</option> \n"
"<option value=\"2006\">2006</option> \n"
"<option value=\"2007\">2007</option> \n"
"<option value=\"2008\">2008</option> \n"
"<option value=\"2009\">2009</option> \n"
"<option value=\"2010\">2010</option> \n"
"<option value=\"2011\">2011</option> \n"
"<option value=\"2012\">2012</option> \n"
"<option value=\"2013\">2013</option> \n"
"<option value=\"2014\">2014</option> \n"
"<option value=\"2015\">2015</option> \n"
"<option value=\"2016\">2016</option> \n"
"<option value=\"2017\">2017</option> \n"
"</select>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")