$re = '/::(?!.*]]$)/m';
$str = 'SID:Common::Location ABE::Sub Location ABE
[[Maps to SID::toto tata]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);