re = /::(?!.*]]$)/m
str = 'SID:Common::Location ABE::Sub Location ABE
[[Maps to SID::toto tata]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end