#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:me+|ee+)(*SKIP)(*FAIL)|e"
Local $sString = "met" & @CRLF & _
"meet" & @CRLF & _
"eel" & @CRLF & _
"elm" & @CRLF & _
"degree" & @CRLF & _
"zookeeper" & @CRLF & _
"meee"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")