$re = '/(?:me+|ee+)(*SKIP)(*FAIL)|e/m';
$str = 'met
meet
eel
elm
degree
zookeeper
meee';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);