#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)(?:\\r)$"
Local $sString = "0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\r" & @CRLF & _
"0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00" & @CRLF & _
"0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\r"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")