$re = '/(.*)(?:\\\\r)$/m';
$str = '0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\\r
0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00
0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\\r';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);