$re = '/<iframe.*src=["\']([^ ^"^\']*)["\']/';
$str = '<iframe width="560" height="315" src="https://www.youtube.com/embed/VsG2t-rKUmA" frameborder="0" allowfullscreen></iframe>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);