re = /<iframe.*src=["\']([^ ^"^\']*)["\']/
str = '<iframe width="560" height="315" src="https://www.youtube.com/embed/VsG2t-rKUmA" frameborder="0" allowfullscreen></iframe>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end