package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}$`)
var str = `/[a-f0-9]{8}(?:-[a-f0-9]{4}){3}-[a-f0-9]{12}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}