re = /^[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}$/
str = '/[a-f0-9]{8}(?:-[a-f0-9]{4}){3}-[a-f0-9]{12}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end