#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b[^\s]+\b)(?!([^\[]*\]))"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit," & @CRLF & _
"sed do eiusmod tempor incididunt ut labore et dolore magna" & @CRLF & _
"aliqua. Ut enim ad minim veniam, quis nostrud exercitation" & @CRLF & _
"ullamco laboris nisi ut aliquip ex ea commodo consequat." & @CRLF & _
"Duis aute irure dolor in reprehenderit in voluptate velit" & @CRLF & _
"esse cillum dolore eu :fugiat: nulla pariatur. Excepteur sint" & @CRLF & _
"occaecat :cupidatat [non] proident:, sunt in culpa qui officia" & @CRLF & _
"deserunt mollit anim id est laborum." & @CRLF & _
"" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz [ABCDEFGHIJKLMNO] PQRSTUVWXYZ" & @CRLF & _
"0123456789 _+-.,!@#$%^&*();\/|<>"'" & @CRLF & _
"12345 -98.7 3.141 .6180 9,000 +42" & @CRLF & _
"555.123.4567 +1-(800)-555-2468" & @CRLF & _
"foo@demo.net <bar.ba@test.co.uk>" & @CRLF & _
"www.demo.com {http://foo.co.uk/ } " & @CRLF & _
"[https://marketplace.visualstudio.com/ite] ms?itemName=chrmarti.regex" & @CRLF & _
"https://github.com/chrmarti/vscode-regex asdfasdf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")