# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b[^\s]+\b)(?!([^\[]*\]))"
test_str = ("Lorem ipsum dolor sit amet, consectetur adipiscing elit,\n"
"sed do eiusmod tempor incididunt ut labore et dolore magna\n"
"aliqua. Ut enim ad minim veniam, quis nostrud exercitation\n"
"ullamco laboris nisi ut aliquip ex ea commodo consequat.\n"
"Duis aute irure dolor in reprehenderit in voluptate velit\n"
"esse cillum dolore eu :fugiat: nulla pariatur. Excepteur sint\n"
"occaecat :cupidatat [non] proident:, sunt in culpa qui officia\n"
"deserunt mollit anim id est laborum.\n\n"
"abcdefghijklmnopqrstuvwxyz [ABCDEFGHIJKLMNO] PQRSTUVWXYZ\n"
"0123456789 _+-.,!@#$%^&*();\\/|<>\"'\n"
"12345 -98.7 3.141 .6180 9,000 +42\n"
"555.123.4567 +1-(800)-555-2468\n"
"foo@demo.net <bar.ba@test.co.uk>\n"
"www.demo.com {http://foo.co.uk/ } \n"
"[https://marketplace.visualstudio.com/ite] ms?itemName=chrmarti.regex\n"
"https://github.com/chrmarti/vscode-regex asdfasdf\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.