package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+\s){3}`)
var str = `2 x Grapes @Walmart`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}