$re = '/(\w+\s){3}/';
$str = '2 x Grapes @Walmart';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);