#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{4}|\d{2})\/(0?[1-9]|1[0-2])\/(0?[1-9]|[12]\d|3[01]), ([AP])M([1-9]|1[0-2]):([0-5]\d) - (.*?): (\D*(?:\d(?!(?:\d{3}|\d)\/(?:0?[1-9]|1[0-2])\/(0?[1-9]|[12]\d|3[01]))\D*)*)(?=\n|$)"
Local $sString = "2012/12/1, AM12:21 - user1: entry1_wasehhjdsaj" & @CRLF & _
"2012/12/2, AM9:42 - user2: entry2_bahbahbah_dsdeead" & @CRLF & _
"2012/12/2, AM9:44 - user3: entry3_Line1_ContdWithFollowingLine_bahbah" & @CRLF & _
"entry3_Line2_ContdWithABoveLine_bahbahbah_erererw" & @CRLF & _
"entry3_Line3_ContdWithABoveLine_bahbahbah_dsff" & @CRLF & _
"2012/12/4, AM11:48 - user7: entry4_bahbahbah_fggf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")