const regex = /^(\d{4}|\d{2})\/(0?[1-9]|1[0-2])\/(0?[1-9]|[12]\d|3[01]), ([AP])M([1-9]|1[0-2]):([0-5]\d) - (.*?): (\D*(?:\d(?!(?:\d{3}|\d)\/(?:0?[1-9]|1[0-2])\/(0?[1-9]|[12]\d|3[01]))\D*)*)(?=\n|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{4}|\\d{2})\\\/(0?[1-9]|1[0-2])\\\/(0?[1-9]|[12]\\d|3[01]), ([AP])M([1-9]|1[0-2]):([0-5]\\d) - (.*?): (\\D*(?:\\d(?!(?:\\d{3}|\\d)\\\/(?:0?[1-9]|1[0-2])\\\/(0?[1-9]|[12]\\d|3[01]))\\D*)*)(?=\\n|$)', 'gm')
const str = `2012/12/1, AM12:21 - user1: entry1_wasehhjdsaj
2012/12/2, AM9:42 - user2: entry2_bahbahbah_dsdeead
2012/12/2, AM9:44 - user3: entry3_Line1_ContdWithFollowingLine_bahbah
entry3_Line2_ContdWithABoveLine_bahbahbah_erererw
entry3_Line3_ContdWithABoveLine_bahbahbah_dsff
2012/12/4, AM11:48 - user7: entry4_bahbahbah_fggf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}