import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ \\t][\\d]{1,6}[ \\t][ \\t]*\\d{1,6}[ \\t]*-{1}[ \\t]*\\d{1,6}";
final String string = "741223-741230\n"
+ " 741220 - 741233, , \n"
+ "741223,741224\n"
+ " 741223, 741224, \n"
+ " 741223 -741225 , 741227-741229,740062- 740064,740065-740069, 727098\n"
+ "741223-741225,741227-741229,740062-740064,740065-740069";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}