use strict;
my $str = '741223-741230
741220 - 741233, ,
741223,741224
741223, 741224,
741223 -741225 , 741227-741229,740062- 740064,740065-740069, 727098
741223-741225,741227-741229,740062-740064,740065-740069';
my $regex = qr/[ \t][\d]{1,6}[ \t][ \t]*\d{1,6}[ \t]*-{1}[ \t]*\d{1,6}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}