use strict;
my $str = '2, 10,11,1,1, 22,1,12,1,1, 1,2 , 2 ,2';
my $regex = qr/(?<!\d)2(?!\d)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";