$re = '/(?<!\d)2(?!\d)/m';
$str = '2, 10,11,1,1, 22,1,12,1,1, 1,2 , 2 ,2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;