const regex = /([\d\.]+)\s(\S*)\s(\S*)\s\[(.*?)\]\s"(.*?)"\s(\d+)\s(\S*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d\\.]+)\\s(\\S*)\\s(\\S*)\\s\\[(.*?)\\]\\s"(.*?)"\\s(\\d+)\\s(\\S*)', '')
const str = `10.223.157.186 - - [15/Jul/2009:15:50:37 -0700] "GET /assets/swf/home-media-block.swf HTTP/1.1" 200 123884`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}