using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cat(*SKIP)(*FAIL)|[^c]*(?:c(?!at)[^c]*)*";
string input = @"I see a cat in the tree.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}