$re = '/cat(*SKIP)(*FAIL)|[^c]*(?:c(?!at)[^c]*)*/';
$str = 'I see a cat in the tree.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);