re = /^(?!.*foo).*$/m
str = 'Text with foo here
foo Text
More foo
Match this line'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end