import re
regex = re.compile(r"^(?!foo$).*$", flags=re.MULTILINE)
test_str = ("Not:\n"
"foo\n"
"But:\n"
"Text with foo hereee\n\n"
"foo Text \n\n"
"More foo\n"
"foo \n"
" ^ whitespace ^\n"
"1\n"
"12\n"
"Match this line\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")