$re = '/\b\S+(?<!\.in)\.c\b/m';
$str = 'in.c
I\'m trying to write a regex that matches a.c, hello.c, etc.c, but not a.in.c, hello.in.c, etc.in.c.
a.c
my.cpp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);