re = /\b\S+(?<!\.in)\.c\b/m
str = 'in.c
I\'m trying to write a regex that matches a.c, hello.c, etc.c, but not a.in.c, hello.in.c, etc.in.c.
a.c
my.cpp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end