$re = '/(?s)(AK[0-9][0-9][0,1])|((?:(?!AK[0-9][0-9][0,1]).)*)/s';
$str = '[Packet1]AK221[Packet2][AK290[Packet3][Packet1]AK991[Packet2][AK191[Packet3]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);