re = /(?s)(AK[0-9][0-9][0,1])|((?:(?!AK[0-9][0-9][0,1]).)*)/
str = '[Packet1]AK221[Packet2][AK290[Packet3][Packet1]AK991[Packet2][AK191[Packet3]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end