package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[-]{0,1}[\\d]+(\\.[\\d]+)?$`)
var str = `0.2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}