$re = '/^[-]{0,1}[\\\\d]+(\\\\.[\\\\d]+)?$/';
$str = '0.2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);