#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^yahoo\.com?(?:(?!\.[a-z]{2}).)*(?:.com?)?$"
Local $sString = "regexp_repalce with negated character class:" & @CRLF & _
"yahoo\.co[^\.].*" & @CRLF & _
"" & @CRLF & _
"https://stackoverflow.com/questions/977251/regular-expressions-and-negating-a-whole-character-group" & @CRLF & _
"^(?!.*ab).*$" & @CRLF & _
"" & @CRLF & _
".es" & @CRLF & _
"" & @CRLF & _
"yahoo.es" & @CRLF & _
"yahoo.fr" & @CRLF & _
"yahoo.ca" & @CRLF & _
"yahoo.cm" & @CRLF & _
"yahoo.cn" & @CRLF & _
"yahoo.tw" & @CRLF & _
"yahoo.co.jp" & @CRLF & _
"yahoo.co.kr" & @CRLF & _
"yahoo.co.uk" & @CRLF & _
"yahoo.com.cn" & @CRLF & _
"yahoo.com.hk" & @CRLF & _
"yahoo.com.mx" & @CRLF & _
"yahoo.com.tw" & @CRLF & _
"" & @CRLF & _
"REPLACE" & @CRLF & _
"yahoo.co" & @CRLF & _
"yahoo.co," & @CRLF & _
"yahoo.com" & @CRLF & _
"yahoo.com," & @CRLF & _
"yahoo.com." & @CRLF & _
"yahoo.com'" & @CRLF & _
"yahoo.com/haltokariev" & @CRLF & _
"yahoo.com>" & @CRLF & _
"yahoo.com21yahoo.com" & @CRLF & _
"yahoo.comcom" & @CRLF & _
"yahoo.comheatdoc1123" & @CRLF & _
"" & @CRLF & _
"yahoo" & @CRLF & _
"yahoomail.com keep" & @CRLF & _
"yahool.com" & @CRLF & _
"yahooo.com" & @CRLF & _
"yahoo.comj" & @CRLF & _
"yahoo.net" & @CRLF & _
"yahoocom" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"yahoo.com.hk" & @CRLF & _
"yahoo.co.uk" & @CRLF & _
"yahoo.es" & @CRLF & _
"yahoo.co" & @CRLF & _
"yahoo.com.tw" & @CRLF & _
"yahoo.fr" & @CRLF & _
"yahoo.ca" & @CRLF & _
"" & @CRLF & _
"gmasucciarchitects.com" & @CRLF & _
"gmirealtyllc.com" & @CRLF & _
"gmarchitects.nett" & @CRLF & _
"gmarchitects.nte" & @CRLF & _
"gmachitects.net" & @CRLF & _
"gmarchitects.net" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"g-mail.com" & @CRLF & _
"g.mail.com" & @CRLF & _
"gailmail.com" & @CRLF & _
"gamail.com" & @CRLF & _
"gaol.com" & @CRLF & _
"geeemail.com" & @CRLF & _
"gemail.com" & @CRLF & _
"gfmail.com" & @CRLF & _
"ggmail.com" & @CRLF & _
"gimail.com" & @CRLF & _
"gmai.com" & @CRLF & _
"gmai9l.com" & @CRLF & _
"gmaiil.com" & @CRLF & _
"gmail" & @CRLF & _
"gmail." & @CRLF & _
"gmail..com" & @CRLF & _
"gmail.c" & @CRLF & _
"gmail.cim" & @CRLF & _
"gmail.cm" & @CRLF & _
"gmail.co" & @CRLF & _
"gmail.com" & @CRLF & _
"gmail.com." & @CRLF & _
"gmail.com.com" & @CRLF & _
"gmail.com101" & @CRLF & _
"gmail.com2014505140" & @CRLF & _
"gmail.com8206" & @CRLF & _
"gmail.comalexandrasceboldsecretary" & @CRLF & _
"gmail.comaol.com" & @CRLF & _
"gmail.combchan43460" & @CRLF & _
"gmail.comc" & @CRLF & _
"gmail.comceciliaschiera" & @CRLF & _
"gmail.comcolecole.cc1" & @CRLF & _
"gmail.comi" & @CRLF & _
"gmail.comil.com" & @CRLF & _
"gmail.comj" & @CRLF & _
"gmail.comjamesesber" & @CRLF & _
"gmail.coml.com" & @CRLF & _
"gmail.comleponto" & @CRLF & _
"gmail.comll" & @CRLF & _
"gmail.comlwilliams102" & @CRLF & _
"gmail.comm" & @CRLF & _
"gmail.comment.com" & @CRLF & _
"gmail.commipg820" & @CRLF & _
"gmail.comn" & @CRLF & _
"gmail.comnaka" & @CRLF & _
"gmail.comnr.aidan.collins" & @CRLF & _
"gmail.comol.com" & @CRLF & _
"gmail.comorapa0013" & @CRLF & _
"gmail.con" & @CRLF & _
"gmail.coom" & @CRLF & _
"gmail.cpm" & @CRLF & _
"gmail.cvom" & @CRLF & _
"gmail.gmail.com" & @CRLF & _
"gmail.net" & @CRLF & _
"gmail.om" & @CRLF & _
"gmail.oom" & @CRLF & _
"gmail.you" & @CRLF & _
"gmail1.com" & @CRLF & _
"gmail8203.com" & @CRLF & _
"gmailc.com" & @CRLF & _
"gmailc.om" & @CRLF & _
"gmailcom" & @CRLF & _
"gmailfurman.com" & @CRLF & _
"gmaill.com" & @CRLF & _
"gmaillcom" & @CRLF & _
"gmailmgmtcom" & @CRLF & _
"gmails.com" & @CRLF & _
"gmailus.com" & @CRLF & _
"gmaiol.com" & @CRLF & _
"gmal.com" & @CRLF & _
"gmale.com" & @CRLF & _
"gmall.com" & @CRLF & _
"gmaol.com" & @CRLF & _
"gmauil.com" & @CRLF & _
"gmial.com" & @CRLF & _
"gmil.com" & @CRLF & _
"gmila.com" & @CRLF & _
"gmmail.com"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)