$re = '/^yahoo\.com?(?:(?!\.[a-z]{2}).)*(?:.com?)?$/m';
$str = 'regexp_repalce with negated character class:
yahoo\\.co[^\\.].*
https://stackoverflow.com/questions/977251/regular-expressions-and-negating-a-whole-character-group
^(?!.*ab).*$
.es
yahoo.es
yahoo.fr
yahoo.ca
yahoo.cm
yahoo.cn
yahoo.tw
yahoo.co.jp
yahoo.co.kr
yahoo.co.uk
yahoo.com.cn
yahoo.com.hk
yahoo.com.mx
yahoo.com.tw
REPLACE
yahoo.co
yahoo.co,
yahoo.com
yahoo.com,
yahoo.com.
yahoo.com\'
yahoo.com/haltokariev
yahoo.com>
yahoo.com21yahoo.com
yahoo.comcom
yahoo.comheatdoc1123
yahoo
yahoomail.com keep
yahool.com
yahooo.com
yahoo.comj
yahoo.net
yahoocom
yahoo.com.hk
yahoo.co.uk
yahoo.es
yahoo.co
yahoo.com.tw
yahoo.fr
yahoo.ca
gmasucciarchitects.com
gmirealtyllc.com
gmarchitects.nett
gmarchitects.nte
gmachitects.net
gmarchitects.net
g-mail.com
g.mail.com
gailmail.com
gamail.com
gaol.com
geeemail.com
gemail.com
gfmail.com
ggmail.com
gimail.com
gmai.com
gmai9l.com
gmaiil.com
gmail
gmail.
gmail..com
gmail.c
gmail.cim
gmail.cm
gmail.co
gmail.com
gmail.com.
gmail.com.com
gmail.com101
gmail.com2014505140
gmail.com8206
gmail.comalexandrasceboldsecretary
gmail.comaol.com
gmail.combchan43460
gmail.comc
gmail.comceciliaschiera
gmail.comcolecole.cc1
gmail.comi
gmail.comil.com
gmail.comj
gmail.comjamesesber
gmail.coml.com
gmail.comleponto
gmail.comll
gmail.comlwilliams102
gmail.comm
gmail.comment.com
gmail.commipg820
gmail.comn
gmail.comnaka
gmail.comnr.aidan.collins
gmail.comol.com
gmail.comorapa0013
gmail.con
gmail.coom
gmail.cpm
gmail.cvom
gmail.gmail.com
gmail.net
gmail.om
gmail.oom
gmail.you
gmail1.com
gmail8203.com
gmailc.com
gmailc.om
gmailcom
gmailfurman.com
gmaill.com
gmaillcom
gmailmgmtcom
gmails.com
gmailus.com
gmaiol.com
gmal.com
gmale.com
gmall.com
gmaol.com
gmauil.com
gmial.com
gmil.com
gmila.com
gmmail.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;