const regex = /((?:(?<=:)|(?<=->)) | (?=->))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?<=:)|(?<=->)) | (?=->))', 'mg')
const str = `7
00: 00: 20,509 -> 00: 00: 25,059
on the data before and does not shy in front of radical solutions such as post privacy back.
8
00: 00: 25,159 -> 00: 00: 27,896
On his blog writes: sower already since 2011
9
00: 00: 27,996 -> 00: 00: 31,784
on the impact of technology on society, politics and economy.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);