$re = '/((?:(?<=:)|(?<=->)) | (?=->))/m';
$str = '7
00: 00: 20,509 -> 00: 00: 25,059
on the data before and does not shy in front of radical solutions such as post privacy back.
8
00: 00: 25,159 -> 00: 00: 27,896
On his blog writes: sower already since 2011
9
00: 00: 27,996 -> 00: 00: 31,784
on the impact of technology on society, politics and economy.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;